Работа с коммутаторами SNR-S2950-24G

Заметки для себя , как им пользоваться. В целом интерфейс похож на CISCO (CISCO Like). Команды особо не отличаются. Все свежие прошивки тут!

  • Interface Range не как в Cisco , а по другому

    SNR-S2950-24G(config)#Interface Ethernet1/25-26
    SNR-S2950-24G(config-if-port-range)#switchport mode trunk
    Set the port Ethernet1/25 mode Trunk successfully
    Set the port Ethernet1/26 mode Trunk successfully
    SNR-S2950-24G(config-if-port-range)#switchport trunk allowed vlan 1000

  • Перевести принудительно с Fiber на Copper

    SNR-S2950-24G(config)#Interface Ethernet1/25
    SNR-S2950-24G(config-if-ethernet1/25)#media-type copper
  • Обновить прошивку коммутатора. Предварительно настроить доступ до TFTP

    SNR-S2950-24G#copy tftp://10.1.0.39/S2950_24G/boot.rom boot.rom
    SNR-S2950-24G#copy tftp://10.1.0.39/S2950_24G/nos.img nos.img
  • Настройка управления

    SNR-S2950-24G#conf
    SNR-S2950-24G(config)#interface Vlan1
    SNR-S2950-24G(config-if-vlan1)#no ip address
    SNR-S2950-24G(config-if-vlan1)#exit
    SNR-S2950-24G(config)#vlan 1000
    SNR-S2950-24G(config-vlan1000)#name MGMT
    SNR-S2950-24G(config-vlan1000)#exit
    SNR-S2950-24G(config)#interface Vlan1000
    SNR-S2950-24G(config-if-vlan1000)#ip address 172.17.17.252 255.255.255.0
    SNR-S2950-24G(config-if-vlan1000)#exit
    SNR-S2950-24G(config)#ip default-gateway 172.17.17.254
    SNR-S2950-24G(config)#ip route 172.17.17.0/24 172.17.17.254
    SNR-S2950-24G(config)#ip route 10.1.0.0/24 172.17.17.254
    SNR-S2950-24G(config)#Interface Ethernet1/25-26
    SNR-S2950-24G(config-if-port-range)#switchport mode trunk
    Set the port Ethernet1/25 mode Trunk successfully
    Set the port Ethernet1/26 mode Trunk successfully
    SNR-S2950-24G(config-if-port-range)#switchport trunk allowed vlan 1000
    SNR-S2950-24G(config-if-port-range)#end

    Можно еще повесить ACL типа кому можно рулить , а кому нет. Но с этим все понятно
  • Сброс настроек в default

    SNR-S2950-24G#
    SNR-S2950-24G#dir
    -rwx 6.4M nos.img
    -rwx 1.3K startup.cfg
    Drive : flash:
    Size:6.7M Used:6.5M Avaliable:218.0K Use:97%

    SNR-S2950-24G#del startup.cfg
    Delete file, Are you sure? (Y/N)?[N]Y
    Delete file ok.

    SNR-S2950-24G#reload
    Process with reboot? [Y/N] Y
  • Посмотреть статус интерфейсов

    SNR-S2950-24G#sh interface ethernet status
    Codes: A-Down — administratively down, a — auto, f — force, G — Gigabit
    Interface Link/Protocol Speed Duplex Vlan Type Alias Name
    1/1 UP/UP a-100M a-FULL 1 FE
    1/2 DOWN/DOWN auto auto 1 FE
    1/3 DOWN/DOWN auto auto 1 FE
    1/4 DOWN/DOWN auto auto 1 FE
    …….
  • Настройка dhcp snooping

    ip dhcp snooping enable
    ip dhcp snooping vlan 150
    ip dhcp snooping binding enable
    !
    ip dhcp snooping information enable
    ip dhcp snooping information option subscriber-id format hex

    vlan 150
    name IPoE
    !
    vlan 204
    name park4 # Допустим старый влан
    !
    vlan 1000
    name MGMT
    !
    vlan 88
    multicast-vlan
    !
    Interface Ethernet1/5
    spanning-tree mst 0 rootguard
    spanning-tree portfast bpdufilter
    switchport access vlan 150
    loopback-detection specified-vlan 150
    loopback-detection control shutdown
    ip dhcp snooping binding user-control
    !
    Interface Ethernet1/26
    description UPLINK
    switchport mode trunk
    switchport trunk allowed vlan 12;88;150;204;1000 # Перечисляем все разрешенные вланы
    ip dhcp snooping trust
    !
    Interface Ethernet1/27
    description Link_4P
    switchport mode trunk
    switchport trunk allowed vlan 12;88;150;204;1000
    ip dhcp snooping trust
    !

Нормуль! Сойдет. Остальное как в Cisco